android_loves_flash

Adobe Flash 10.1 Working On Evo And Other HTC Devices Without Froyo

June 17, 2010 - Written By Chris Yackulic

One of the members at xda-developers has managed to compile an APK for Android 2.0 and 2.1, giving users full Flash support on their device!

Achieved by using a plugin on Android 2.x currently used to enable Flash Lite, the APK that’s been created will remove the Lite version of Flash, replacing it with the full version used on Android 2.2.

Android 2.2 has a new feature called com.google.android.feature.GOOGLE_PLUGIN. And Flash usesit to embed itself inside browser. So browser in 2.1 does not see plugin.

BUT!There’s another thing inside – a permission called android.webkit.permission.PLUGIN. It is already used by Flash Lite on HTC devices. So my APK will work and replace Flash Lite. But I did not test, because I do own… Acer Liquid!

So! HTC users! Try this one! And if it will work instead of your flash lite – report. Your help will be used to port full-blown Flash to other 2.0 and 2.1 devices (yeah! 2.0 is also supported!).

A post at Android Central has shown Flash Player 10.1 up and running on the EVO 4G and Sprint Hero, meaning that any other device running Android 2.x could potentially have full Flash support too.

This hasn’t been fully confirmed yet, with some users reporting issues or little difference over Flash Lite. If you want to try it out for yourself, head over to xda-developers and download the installer to give it a go. Don’t forget to let us know how you fare in the comments!